The persistent-sqlite package

[Tags: library, mit]

This package includes a thin sqlite3 wrapper based on the direct-sqlite package, as well as the entire C library, so there are no system dependencies.


Properties

Versions0.0.0, 0.1.0, 0.1.1, 0.2.0, 0.2.1, 0.2.2, 0.2.2.1, 0.3.0, 0.3.0.1, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.2.1, 0.7.0, 0.8.0, 0.9.0, 0.9.0.1, 0.9.0.2, 1.0.0, 1.0.1, 1.1.0, 1.1.2, 1.1.3, 1.1.3.1, 1.1.4, 1.1.4.1, 1.1.5, 1.2.0, 1.2.1, 1.3.0, 1.3.0.1, 1.3.0.2, 1.3.0.3, 1.3.0.4, 1.3.0.5, 2.0.0, 2.0.0.1, 2.0.1, 2.0.3, 2.0.4, 2.0.5, 2.1, 2.1.0.1, 2.1.1, 2.1.1.1 (info)
Dependenciesbase (==4.*), bytestring (>=0.9.1 && <0.10), containers (>=0.2 && <0.4), MonadCatchIO-transformers (>=0.2.2 && <0.3), persistent (>=0.2.2 && <0.3), template-haskell (==2.4.*), transformers (>=0.2.1 && <0.3), utf8-string (>=0.3.4 && <0.4)
LicenseBSD3
AuthorMichael Snoyman <michael@snoyman.com>
MaintainerMichael Snoyman <michael@snoyman.com>
StabilityStable
CategoryDatabase
Home pagehttp://docs.yesodweb.com/persistent/
Source repositoryhead: git clone git://github.com/snoyberg/persistent.git
UploadedWed Oct 6 19:37:18 UTC 2010 by MichaelSnoyman
DistributionsDebian:1.3.0.5, FreeBSD:1.2.0, NixOS:2.1.1, Stackage:2.1.1.1
Downloads25229 total (1309 in last 30 days)
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefault
systemlibUse the system-wide sqlite libraryDisabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees