The persistent-sqlite package

[Tags: library, mit]

This package includes a thin sqlite3 wrapper based on the direct-sqlite package, as well as the entire C library, so there are no system dependencies.


Properties

Versions0.0.0, 0.1.0, 0.1.1, 0.2.0, 0.2.1, 0.2.2, 0.2.2.1, 0.3.0, 0.3.0.1, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.6.2.1, 0.7.0, 0.8.0, 0.9.0, 0.9.0.1, 0.9.0.2, 1.0.0, 1.0.1, 1.1.0, 1.1.2, 1.1.3, 1.1.3.1, 1.1.4, 1.1.4.1, 1.1.5, 1.2.0, 1.2.1, 1.3.0, 1.3.0.1, 1.3.0.2, 1.3.0.3, 1.3.0.4, 1.3.0.5, 2.0.0, 2.0.0.1
Dependenciesaeson (>=0.5), base (==4.*), bytestring (>=0.9.1), conduit (>=0.5.3), containers (>=0.2), monad-control (>=0.2), monad-logger (>=0.2.4), persistent (==2.0.*), persistent-sqlite, resourcet (>=1.1), text (>=0.7), transformers (>=0.2.1)
LicenseMIT
AuthorMichael Snoyman <michael@snoyman.com>
MaintainerMichael Snoyman <michael@snoyman.com>
StabilityStable
CategoryDatabase, Yesod
Home pagehttp://www.yesodweb.com/book/persistent
Bug trackerhttps://github.com/yesodweb/persistent/issues
Source repositoryhead: git clone git://github.com/yesodweb/persistent.git
Executablessanity
Upload dateThu Aug 28 02:27:36 UTC 2014
Uploaded byMichaelSnoyman
DistributionsDebian:1.3.0.5, FreeBSD:1.2.0, NixOS:1.3.0.5
Downloads17382 total (1856 in last 30 days)

Modules

[Index]

Flags

NameDescriptionDefault
systemlibUse the system-wide sqlite libraryDisabled
build-sanity-exeBuild a sanity check test executableDisabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees