The pipes-lines package

[Tags:bsd3, deprecated, library, test]
Deprecated. in favor of pipes-break

Deprecated: This library is deprecated in favor of pipes-break, which is simpler, better tested, has more utility, has better understood semantics, and includes lens support.

pipes-lines contains utility functions for splitting lines that involve carriage returns aka lines ending in \r\n

These are utility functions that were omitted from pipes-bytestring and pipes-text

Properties

Versions 1.0.0.0, 1.0.1, 1.0.2, 1.0.3.1, 1.0.3.2, 1.0.3.3, 1.0.3.4
Dependencies base (>=4.7 && <5.0), bytestring (>=0.10 && <0.12), pipes (>=4.0 && <5.0), pipes-group (>=1.0 && <2.0), text (>=1.2 && <2.0) [details]
License BSD3
Copyright 2017 David McHealy
Author David McHealy
Maintainer david.mchealy@gmail.com
Category Pipes, Control
Home page https://github.com/mindreader/pipes-lines
Bug tracker https://github.com/mindreader/pipes-lines/issues
Source repository head: git clone https://github.com/mindreader/pipes-lines
Uploaded Thu Mar 16 17:18:23 UTC 2017 by mindreader
Distributions NixOS:1.0.3.4
Downloads 192 total (22 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2017-03-16 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees