The postgresql-syntax package

[ Tags: database, deprecated, library, mit, postgresql ] [ Propose Tags ]
Deprecated.

Currently this library only provides an SQL syntax validator.

This library wraps the "libpq_query" C library, which is an SQL parser based on the source code of the Postgres server. IOW, it uses the same parser as Postgres itself and hence supports all of its syntax.

So far this package has only been tested to work on the *nix systems (Mac OS including).

Properties

Versions 0.1
Dependencies base (<5), base-prelude (<2), bytestring (>=0.10.8 && <0.11), text (==1.*) [details]
License MIT
Copyright (c) 2017, Nikita Volkov
Author Nikita Volkov <nikita.y.volkov@mail.ru>
Maintainer Nikita Volkov <nikita.y.volkov@mail.ru>
Category Database, PostgreSQL
Home page https://github.com/nikita-volkov/postgresql-syntax
Bug tracker https://github.com/nikita-volkov/postgresql-syntax/issues
Source repository head: git clone git://github.com/nikita-volkov/postgresql-syntax.git
Uploaded Mon Mar 6 21:15:26 UTC 2017 by NikitaVolkov
Distributions NixOS:0.1
Downloads 91 total (8 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2017-03-06 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees