The pulseaudio package

[Tags:lgpl, library]

This package mainly exists, because I wanted to query the current system volume from the pulse audio server.

Doing this required me to build at least the core of the pulse api.

This package is provided as is, with very little testing and only a small subset of the pulse api implemented. Expanding this package *should* be rather easy. At least for query/control. If you are interested in doing this, but don't know how, feel free to contact me.

In package is a bit unrefined and rough. If you have better structure for modules feel free to reorganize them and making a PR. This also means, don't see this structur as fixed yet, it may change if someone has a better idea.

Properties

Versions 0.0.1.0, 0.0.1.1, 0.0.2.0
Change log ChangeLog.md
Dependencies base (>=4.6.0.1 && <4.10), containers, pulseaudio, stm, transformers, unix [details]
License LGPL-3
Author Markus Ongyerth
Maintainer ongy@ongy.net
Stability Unknown
Category Sound
Source repository head: git clone https://github.com/ongy/pulseaudio
Uploaded Wed Feb 15 10:45:02 UTC 2017 by ongyerth
Distributions NixOS:0.0.2.0
Downloads 105 total (15 in the last 30 days)
Votes
0 []
Status Docs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees