The puzzle-draw-cmdline package

[Tags:deprecated, mit, program]
Deprecated. in favor of puzzle-draw

Companion executable to puzzle-draw. Separate to keep the dependency on diagrams-cairo out of the library.

[Skip to Readme]


Change log
Dependencies aeson (==0.7.*), base (>=4.2 && <4.8), diagrams-cairo (>=1.0 && <1.2), diagrams-lib (>=1.0 && <1.2), diagrams-svg (>=1.0 && <1.2), filepath (==1.3.*), optparse-applicative (>=0.7 && <0.9), puzzle-draw (>= && <0.1.1), yaml (==0.8.*) [details]
License MIT
Author Robert Vollmert
Stability Unknown
Category Graphics
Source repository head: git clone
Uploaded Sat Apr 19 10:30:08 UTC 2014 by vollmert
Distributions NixOS:
Downloads 898 total (14 in the last 30 days)
0 []
Status Docs not available [build log]
All reported builds failed as of 2015-11-13 [all 5 reports]


cairoBuild against Cairo backendDisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info


Maintainer's Corner

For package maintainers and hackage trustees

Readme for puzzle-draw-cmdline

Readme for puzzle-draw-cmdline-


Rendering logic puzzles, command-line support.

See puzzle-draw for the main part of this project.

This repository was split out to move the dependency on cairo out of puzzle-draw.

To enable the Cairo backend (required for png/pdf/ps output), use $ cabal install -f cairo