RabbitMQ: AMQP 0-9-1 client library for RabbitMQ servers

[ library, network ] [ Propose Tags ]

This library provides an AMQP 0-9-1 client library for RabbitMQ servers.

This library is a fork of the amqp package based on HsOpenSSL for providing TLS support.

See Network.AMQP for documentation and a usage example.

Versions [faq] 0.1.0.0
Dependencies array (>=0.5.0.0 && <0.6), base (>=4.7.0 && <4.8 || >=4.8.0 && <4.9 || >=4.9.0 && <4.10 || >=4.10.0 && <4.11 || >=4.11.0 && <4.12 || >=4.12.0 && <4.13 || >=4.13.0 && <4.14), binary (>=0.7.1 && <0.9), bytestring (>=0.10.4 && <0.11), clock (==0.8.*), containers (>=0.5.5 && <0.7), HsOpenSSL (>=0.11.4 && <0.12), io-streams (>=1.5.1 && <1.6), monad-control (>=1.0.2 && <1.1), network (==2.8.* || >=3.0 && <3.2), network-uri (==2.6.*), openssl-streams (>=1.2.2 && <1.3), split (>=0.2.3 && <0.3), stm (==2.5.*), text (>=1.2.3 && <1.3), vector (==0.12.*) [details]
License BSD-3-Clause AND GPL-3.0-or-later[multiple license files]
Author Holger Reinhardt, Herbert Valerio Riedel
Maintainer hvr@gnu.org
Revised Revision 1 made by HerbertValerioRiedel at 2019-09-10T12:01:58Z
Category Network
Bug tracker https://github.com/hvr/RabbitMQ/issues
Source repo head: git clone https://github.com/hvr/RabbitMQ.git
Uploaded by HerbertValerioRiedel at 2019-08-22T00:03:50Z
Distributions NixOS:0.1.0.0
Downloads 404 total (16 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-08-22 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees