accelerate-cuda: Accelerate backend for NVIDIA GPUs

[ bsd3, compilers-interpreters, concurrency, data, deprecated, library, parallelism ] [ Propose Tags ]
Deprecated. in favor of accelerate-llvm-ptx

This library implements a backend for the Accelerate language instrumented for parallel execution on CUDA-capable NVIDIA GPUs.

To use this backend you need CUDA version 3.x or later installed. Note that currently there is no support for Char and Bool arrays (this is a limitation of the front-end language).

Versions 0.12.0.0, 0.12.1.0, 0.12.1.1, 0.12.1.2, 0.13.0.0, 0.13.0.1, 0.13.0.2, 0.13.0.3, 0.13.0.4, 0.14.0.0, 0.15.0.0, 0.15.1.0, 0.15.1.1, 0.16.0.0, 0.17.0.0 (info)
Dependencies accelerate (==0.12.*), array (>=0.3), base (==4.*), binary (>=0.5), blaze-builder (>=0.3), bytestring (>=0.9), containers (>=0.4), cryptohash (>=0.7), cuda (>=0.4.1), directory (>=1.0), fclabels (>=1.0), filepath (>=1.0), hashable (>=1.1), hashtables (>=1.0.1), language-c-quote (>=0.3), mainland-pretty (>=0.1.1), mtl (>=2.0), pretty (>=1.0), process (>=1.0), srcloc (>=0.1), symbol (>=0.1), transformers (>=0.2), unix (>=2.4), unordered-containers (>=0.1.4), Win32 (>=2.2.1) [details]
License BSD-3-Clause
Author Manuel M T Chakravarty, Gabriele Keller, Sean Lee, Trevor L. McDonell
Maintainer Trevor L. McDonell <tmcdonell@cse.unsw.edu.au>
Category Compilers/Interpreters, Concurrency, Data, Parallelism
Home page http://www.cse.unsw.edu.au/~chak/project/accelerate/
Bug tracker https://github.com/AccelerateHS/accelerate/issues
Source repo head: git clone https://github.com/AccelerateHS/accelerate-cuda
Uploaded by ManuelChakravarty at Mon May 14 06:02:35 UTC 2012
Distributions NixOS:0.17.0.0
Downloads 7715 total (23 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2016-12-24 [all 8 reports]
Hackage Matrix CI

Modules

  • Data
    • Array
      • Accelerate
        • Data.Array.Accelerate.CUDA

Flags

NameDescriptionDefaultType
debug

Enable tracing message flags

DisabledAutomatic
bounds-checks

Enable bounds checking

EnabledAutomatic
unsafe-checks

Enable bounds checking in unsafe operations

DisabledAutomatic
internal-checks

Enable internal consistency checks

DisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees