cabal-lenses: Lenses and traversals for the Cabal library.

[ bsd3, development, library, utils ] [ Propose Tags ]

Lenses and traversals (compatible with the lens library) for the Cabal library.


[Skip to Readme]
Versions [faq] 0.1, 0.2, 0.3, 0.3.1, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.4.8, 0.4.9, 0.5.0, 0.6.0, 0.7.0, 0.7.1, 0.8.0, 0.9.0
Change log CHANGELOG
Dependencies base (>=4.8 && <5), Cabal (>=2.1.0.0 && <2.5), lens (>=4.0.1 && <4.18), strict (>=0.3.2 && <0.4), system-fileio (>=0.3.12 && <0.4), system-filepath (>=0.4.9 && <0.5), text (>=1.1.0.1 && <1.3), transformers (>=0.4.1.0 && <0.6), unordered-containers (>=0.2.3.3 && <0.3) [details]
License BSD-3-Clause
Author Daniel Trstenjak
Maintainer daniel.trstenjak@gmail.com
Revised Revision 1 made by HerbertValerioRiedel at Thu Jan 3 19:42:49 UTC 2019
Category Utils, Development
Source repo head: git clone https://github.com/dan-t/cabal-lenses
Uploaded by DanielTrstenjak at Thu Jan 3 16:48:25 UTC 2019
Distributions NixOS:0.9.0
Downloads 6478 total (332 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-01-03 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees


Readme for cabal-lenses-0.9.0

[back to package description]

cabal-lenses

Lenses and traversals (compatible with the lens library) for the Cabal library.