exception-transformers: Type classes and monads for unchecked extensible exceptions.

[ bsd3, control, error-handling, failure, library, monad ] [ Propose Tags ]

This package provides type classes, a monad and a monad transformer that support unchecked extensible exceptions as well as asynchronous exceptions. It is compatible with the transformers package.

Versions 0.2, 0.3, 0.3.0.1, 0.3.0.2, 0.3.0.3, 0.3.0.4, 0.4, 0.4.0.1, 0.4.0.2, 0.4.0.3, 0.4.0.4, 0.4.0.5, 0.4.0.6, 0.4.0.7
Dependencies base (==4.*), stm (>=2.1 && <2.6), transformers (>=0.2 && <0.6), transformers-compat (>=0.3 && <0.7) [details]
License BSD-3-Clause
Copyright (c) 2009-2010 Harvard University (c) 2011-2018 Geoffrey Mainland
Author Geoffrey Mainland <mainland@drexel.edu>
Maintainer Geoffrey Mainland <mainland@drexel.edu>
Revised Revision 1 made by HerbertValerioRiedel at Tue Oct 2 11:30:01 UTC 2018
Category Control, Monad, Error Handling, Failure
Bug tracker https://github.com/mainland/exception-transformers/issues
Source repo head: git clone git://github.com/mainland/exception-transformers.git
Uploaded by GeoffreyMainland at Sat May 5 20:49:44 UTC 2018
Distributions Debian:0.4.0.7, LTSHaskell:0.4.0.7, NixOS:0.4.0.7
Downloads 10168 total (77 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2018-05-05 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees