fay-base: The base package for Fay.

[ bsd3, development, fay, library ] [ Propose Tags ]

The base package for Fay. This package amongst others exports Prelude and FFI which you probably want to use with Fay.


[Skip to Readme]
Versions [faq] 0.1.0.0, 0.14.0.0, 0.14.1.0, 0.14.2.0, 0.14.3.0, 0.14.3.1, 0.14.3.2, 0.16.0.0, 0.17.0.0, 0.18.0.0, 0.19, 0.19.1, 0.19.1.1, 0.19.1.2, 0.19.2, 0.19.2.1, 0.19.3, 0.19.4, 0.19.4.1, 0.19.4.2, 0.20.0.0, 0.20.0.1, 0.21.0.0, 0.21.1.0, 0.21.1.1
Change log CHANGELOG.md
Dependencies base (>=4 && <4.7), fay (==0.19.*) [details]
License BSD-3-Clause
Copyright 2012 Chris Done
Author Chris Done
Maintainer adam@bergmark.nl
Revised Revision 1 made by AdamBergmark at 2015-05-19T15:01:42Z
Category Development, Fay
Home page https://github.com/faylang/fay-base
Bug tracker https://github.com/faylang/fay-base/issues
Source repo head: git clone https://github.com/faylang/fay.git
Uploaded by AdamBergmark at 2014-01-14T20:08:12Z
Distributions NixOS:0.21.1.1
Downloads 21929 total (36 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Successful builds reported [all 1 reports]

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees


Readme for fay-base-0.19

[back to package description]

fay-base

Changelog

This package exports Prelude, FFI and other modules which you probably want to use with Fay.

Anything essential for using the compiler, or modules exported by GHC's base can go in this package.

The major version number is coupled with Fay itself, so fay 0.18.* should be used with fay-base 0.18.*.