kafka-client: Low-level Haskell client library for Apache Kafka 0.7.

[ deprecated, library, mit, network ] [ Propose Tags ]
Deprecated.

This package implements a low-level client client library to interface with Apache Kafka 0.7.

Kafka 0.8 and newer are not yet supported.


[Skip to Readme]

Flags

Automatic Flags
NameDescriptionDefault
integration

Enable integration tests.

Disabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Candidates

  • No Candidates
Versions [RSS] 0.7.0.0, 0.7.0.1
Change log CHANGES.md
Dependencies base (>=4.7 && <4.9), bytestring (>=0.10), cereal (>=0.4), digest (>=0.0.1), dlist (>=0.7), network (>=2.4), snappy (>=0.2), time (>=1.4), zlib (>=0.5) [details]
License MIT
Author Abhinav Gupta
Maintainer Abhinav Gupta <mail@abhinavg.net>
Category Network
Home page https://github.com/abhinav/kafka-client
Source repo head: git clone git://github.com/abhinav/kafka-client.git
Uploaded by abhinav at 2015-06-02T02:28:22Z
Distributions NixOS:0.7.0.1
Downloads 1690 total (12 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2015-06-03 [all 1 reports]

Readme for kafka-client-0.7.0.1

[back to package description]

kafka-client

This package provides a low-level Haskell client for Apache Kafka 0.7. Kafka 0.8 and newer are not yet supported.

Package documentation is available on Hackage and here.

Why Kafka 0.7?
I needed to interact with a system running Kafka 0.7.
Will 0.8 or newer be supported?
There are currently no plans to do so. Unless I end up needing to also interact with a Kafka 0.8 system, or receive a pull request, the answer is no.