language-puppet: Tools to parse and evaluate the Puppet DSL.

[ bsd3, library, program, system ] [ Propose Tags ]

This is a set of tools that is supposed to fill all your Puppet needs : syntax checks, catalog compilation, PuppetDB queries, simulationg of complex interactions between nodes, Puppet master replacement, and more !

Versions [faq] 0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.1.7.2, 0.1.8.0, 0.2.0, 0.2.0.1, 0.2.0.2, 0.2.2.0, 0.3.0.0, 0.3.1.0, 0.3.2, 0.4.0, 0.4.2, 0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4, 0.10.5, 0.10.6, 0.11.0, 0.11.1, 0.11.1.1, 0.12.0, 0.12.1, 0.12.2, 0.12.3, 0.13.0, 0.14.0, 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.1.1.1, 1.1.1.2, 1.1.3, 1.1.3.1, 1.1.4, 1.1.4.1, 1.1.5, 1.1.5.1, 1.2, 1.3, 1.3.1, 1.3.1.1, 1.3.2, 1.3.2.1, 1.3.3, 1.3.4, 1.3.4.1, 1.3.5, 1.3.5.1, 1.3.6, 1.3.7, 1.3.8, 1.3.8.1, 1.3.9, 1.3.10, 1.3.11, 1.3.12, 1.3.12.1, 1.3.13, 1.3.14, 1.3.15, 1.3.16, 1.3.17, 1.3.18, 1.3.18.1, 1.3.19, 1.3.19.1, 1.3.20, 1.3.20.1, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.6.1, 1.4.6.2
Change log CHANGELOG.markdown
Dependencies aeson (>=0.7 && <0.9), ansi-wl-pprint (==0.6.*), attoparsec (>=0.11 && <0.13), base (>=4.6 && <4.9), base16-bytestring (==0.1.*), bytestring, case-insensitive (==1.2.*), containers (==0.5.*), cryptohash (>=0.10 && <0.12), Diff, directory (==1.2.*), either (==4.3.*), exceptions (==0.8.*), filecache (>=0.2.8 && <0.3), Glob, hashable (==1.2.*), hruby (==0.3.*), hslogger (==1.2.*), hslua (>=0.3.10 && <0.4), hspec (>=1.9), language-puppet, lens (>=4.9 && <5), lens-aeson (>=1.0), luautils (==0.1.3.*), mtl (==2.2.*), operational (>=0.2.3 && <0.3), optparse-applicative (>=0.11), parallel-io, parsec (==3.1.*), parsers (>=0.11 && <0.13), pcre-utils (>=0.1.4 && <0.2), process (>=1.1 && <1.3), regex-pcre-builtin (>=0.94.4), scientific (>=0.2 && <0.4), servant (==0.2.*), servant-client (==0.2.*), split (==0.2.*), stm (==2.4.*), strict-base-types (>=0.2.2), text (>=0.11), time (>=1.4 && <2), transformers (==0.4.*), unix (>=2.6 && <2.8), unordered-containers (==0.2.*), vector (==0.10.*), yaml (>=0.8.8 && <0.9) [details]
License BSD-3-Clause
Author Simon Marechal
Maintainer bartavelle@gmail.com
Category System
Home page http://lpuppet.banquise.net/
Source repo head: git clone git://github.com/bartavelle/language-puppet.git
Uploaded by SimonMarechal at Mon Apr 20 16:15:39 UTC 2015
Distributions LTSHaskell:1.4.5, NixOS:1.4.6.2
Executables pdbquery, puppetresources
Downloads 42629 total (2858 in the last 30 days)
Rating 2.0 (votes: 1) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs not available [build log]
All reported builds failed as of 2016-12-10 [all 7 reports]

Modules

  • Erb
    • Erb.Evaluate
    • Erb.Parser
    • Erb.Ruby
  • Facter
  • Hiera
    • Hiera.Server
  • Puppet
    • Puppet.Daemon
    • Puppet.Interpreter
      • Puppet.Interpreter.IO
      • Puppet.Interpreter.PrettyPrinter
      • Puppet.Interpreter.Pure
      • Puppet.Interpreter.Resolve
      • Puppet.Interpreter.Types
    • Puppet.Lens
    • Puppet.NativeTypes
      • Puppet.NativeTypes.Helpers
    • Puppet.OptionalTests
    • Puppet.PP
    • Puppet.Parser
      • Puppet.Parser.PrettyPrinter
      • Puppet.Parser.Types
    • Puppet.Preferences
    • Puppet.Stats
    • Puppet.Stdlib
    • Puppet.Utils
  • PuppetDB
    • PuppetDB.Common
    • PuppetDB.Dummy
    • PuppetDB.Remote
    • PuppetDB.TestDB
  • SafeProcess

Downloads

Maintainer's Corner

For package maintainers and hackage trustees