The monadfibre package

[Tags:deprecated, gpl, library]
Deprecated.

This package defines Monadic functions which provide Choice and Parallelism - (<||&rt;) and (<&&&rt;) - that work on Monads that provide a (MonadBi m IO) instance. Depends on the monadbi library for extracting the IO actions from m. Also provides a good example of how to use the library.


[Skip to Readme]

Properties

Versions 0.1, 0.1.1, 0.1.2, 0.1.2.1
Dependencies base (>=3 && <5), monadbi (>=0.1 && <1.0) [details]
License GPL
Author Anupam Jain
Maintainer ajnsit@gmail.com
Stability Experimental
Category Control
Home page https://github.com/ajnsit/monadfibre
Source repository head: git clone http://github.com/ajnsit/monadfibre
this: git clone http://github.com/ajnsit/monadfibre/tree/v0.1.2.1(tag v0.1.2.1)
Uploaded Thu Sep 22 12:41:11 UTC 2011 by AnupamJain
Distributions NixOS:0.1.2.1
Downloads 824 total (21 in the last 30 days)
Votes
0 []
Status Docs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Readme for monadfibre

Readme for monadfibre-0.1.2.1

Monad Fibre (monadfibre-0.1.2.1)
===============================

This package defines Monadic functions which provide Choice and Parallelism - (&lt;||&rt;) and (&lt;&&&rt;) - that work on Monads that provide a (MonadBi m IO) instance.


Changelog
=========

0.1.2.1 : Removed dependency on STM

0.1.2 : Moved MonadBi to a separate library (monadbi). This library provides a good example of how to use MonadBi.

0.1.1 : Removed @Fibre@ monad transformer. Instead only two functions (<||>) and (<&&>) are provided that work on Monads that provide a (MonadBi m ()) instance.

0.1 : Intial release