The fay-base package

[Tags:bsd3, library]

The base package for Fay. This package amongst others exports Prelude and FFI which you probably want to use with Fay.


[Skip to Readme]

Properties

Versions 0.1.0.0, 0.14.0.0, 0.14.1.0, 0.14.2.0, 0.14.3.0, 0.14.3.1, 0.14.3.2, 0.16.0.0, 0.17.0.0, 0.18.0.0, 0.19, 0.19.1, 0.19.1.1, 0.19.1.2, 0.19.2, 0.19.2.1, 0.19.3, 0.19.4, 0.19.4.1, 0.19.4.2, 0.20.0.0, 0.20.0.1
Change log CHANGELOG.md
Dependencies base (>=4 && <4.7), fay (==0.19.*) [details]
License BSD3
Copyright 2012 Chris Done
Author Chris Done
Maintainer adam@bergmark.nl
Stability Unknown
Category Development, Fay
Home page https://github.com/faylang/fay-base
Bug tracker https://github.com/faylang/fay-base/issues
Source repository head: git clone https://github.com/faylang/fay.git
Uploaded Tue Jan 14 20:08:12 UTC 2014 by AdamBergmark
Updated Tue May 19 15:01:42 UTC 2015 by AdamBergmark to revision 1
Distributions LTSHaskell:0.20.0.1, NixOS:0.20.0.1, Stackage:0.20.0.1, Tumbleweed:0.20.0.1
Downloads 7065 total (45 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Successful builds reported [all 1 reports]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Readme for fay-base

Readme for fay-base-0.19

fay-base

Changelog

This package exports Prelude, FFI and other modules which you probably want to use with Fay.

Anything essential for using the compiler, or modules exported by GHC's base can go in this package.

The major version number is coupled with Fay itself, so fay 0.18.* should be used with fay-base 0.18.*.