The jsc package

[Tags:deprecated, library, mit]
Deprecated. in favor of jsaddle

This package provides an EDSL for calling JavaScript code using the JavaScriptCore engine and low level Haskell bindings in the webkit-javascriptcore library


Dependencies base (<5), jmacro (>=0.6.3 && <0.8), lens (>=3.8.5 && <4.1), template-haskell, text (>= && <1.2), transformers (>= && <0.4), webkit (>=0.12.5 && <0.13), webkit-javascriptcore (>=0.12.5 && <0.13), webkitgtk3 (>=0.12.5 && <0.13), webkitgtk3-javascriptcore (>=0.12.5 && <0.13) [details]
License MIT
Author Hamish Mackenzie
Maintainer Hamish Mackenzie <>
Stability Unknown
Category Web, Javascript
Source repository head: git clone
Uploaded Sun Mar 2 17:41:37 UTC 2014 by HamishMackenzie
Distributions NixOS:
Downloads 484 total (5 in the last 30 days)
0 []
Status Docs uploaded by user [build log]
All reported builds failed [all 1 reports]




gtk3Use GTK3 rather than GTK2EnabledAutomatic
jsffiUse JavaScriptFFI extension for GHCJS JavaScript outputEnabledAutomatic
webkitUse WebKitGtk and JavaScriptCore for GHCJS outputDisabledAutomatic
jmacroInclude some JMacro supportEnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info


Maintainer's Corner

For package maintainers and hackage trustees