The network-api-support package

[ Tags: bsd3, library, network-apis ] [ Propose Tags ]

Toolkit for building http client libraries over Network.Http.Conduit.

Note: This library is under heavy development, currently the library is functional but undocumented. Examples of use can be found in the pin and postmark client libraries. Basically expect improvements and change.

Properties

Versions 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.7, 0.0.8, 0.1.0, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.3.0, 0.3.1, 0.3.2
Dependencies aeson (>=0.5), attoparsec (>=0.10), base (>=3 && <5), bytestring (>=0.9), case-insensitive (>=0.4), certificate (>=1.2), failure (>=0.2), http-conduit (>=1.4), http-types (>=0.6), resourcet (>=0.3), text (>=0.11), time (>=1), tls (>=0.9), tls-extra (>=0.4), transformers (>=0.2) [details]
License BSD3
Copyright (c) 2012 Mark Hibberd
Author Mark Hibberd <mark@hibberd.id.au>
Maintainer Mark Hibberd <mark@hibberd.id.au>
Category Network APIs
Home page https://github.com/apiengine/network-api-support
Bug tracker https://github.com/apiengine/network-api-support/issues
Source repository head: git clone https://github.com/apiengine/network-api-support.git
Uploaded Sun Jan 27 23:12:30 UTC 2013 by MarkHibberd
Distributions NixOS:0.3.2
Downloads 3647 total (261 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
small_base

Choose the new, split-up base package.

EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees