hls-hlint-plugin: Hlint integration plugin with Haskell Language Server

[ apache, development, library ] [ Propose Tags ]

Modules

  • Ide
    • Plugin
      • Ide.Plugin.Hlint

Flags

Manual Flags

NameDescriptionDefault
pedantic

Enable -Werror

Disabled
ghc-lib

Force dependency on ghc-lib-parser even if GHC API in the ghc package is supported

Disabled
Automatic Flags
NameDescriptionDefault
hlint33

Hlint-3.3 doesn't support versions ghc-lib < 9.0.1 nor ghc <= 8.6, so we can use hlint-3.2 for backwards compat This flag can be removed when all dependencies support ghc-lib-9.0.* and we drop support for ghc-8.6

Enabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Candidates

Versions [RSS] 0.1.0.0, 0.2.0.0, 1.0.0.1, 1.0.0.2, 1.0.1.0, 1.0.1.1, 1.0.2.0, 1.0.2.1, 1.0.3.0, 1.0.4.0
Dependencies aeson, apply-refact (>=0.9.3.0), base (>=4.12 && <5), binary, bytestring, containers, data-default, deepseq, Diff (>=0.4.0 && <0.5), directory, extra, filepath, ghc, ghc-exactprint (>=0.6.3.4), ghc-lib (>=8.10.7.20210828 && <8.11 || >=9.0 && <9.1), ghc-lib-parser-ex, ghcide (>=1.7 && <1.8), hashable, hlint (>=3.2 && <3.4), hls-plugin-api (>=1.4 && <1.5), hslogger, lens, lsp, refact, regex-tdfa, stm, temporary, text, transformers, unordered-containers [details]
License Apache-2.0
Copyright The Haskell IDE Team
Author The Haskell IDE Team
Maintainer atreyu.bbb@gmail.com
Category Development
Uploaded by hls_team at 2022-04-27T09:22:30Z
Distributions Arch:1.0.1.1, NixOS:1.0.4.0
Downloads 2437 total (177 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2022-04-28 [all 2 reports]