The stack package

[ Tags: bsd3, development, library, program ] [ Propose Tags ]

Please see the README.md for usage information, and the wiki on Github for more details. Also, note that the API for the library is not currently stable, and may change significantly, even between minor releases. It is currently only intended for use by the executable.


[Skip to Readme]

Properties

Versions 0.0.0, 0.0.1, 0.0.2, 0.0.2.1, 0.0.3, 0.1.0.0, 0.1.1.0, 0.1.2.0, 0.1.3.0, 0.1.3.1, 0.1.4.0, 0.1.4.1, 0.1.5.0, 0.1.6.0, 0.1.8.0, 0.1.10.0, 0.1.10.1, 1.0.0, 1.0.2, 1.0.4, 1.0.4.1, 1.0.4.2, 1.0.4.3, 1.1.0, 1.1.2, 1.2.0, 1.3.0, 1.3.2, 1.4.0, 1.5.0, 1.5.1, 1.6.1, 9.9.9 (info)
Change log ChangeLog.md
Dependencies aeson (>=1.1.2.0 && <1.2 || >=1.2.3.0 && <1.3), annotated-wl-pprint (>=0.7.0 && <0.8), ansi-terminal (>=0.7.1.1 && <0.8), async (>=2.1.1.1 && <2.2), attoparsec (>=0.13.1.0 && <0.14), base (>=4.9 && <5), base64-bytestring (>=1.0.0.1 && <1.1), bindings-uname (==0.1.*), blaze-builder (>=0.4.0.2 && <0.5), bytestring (>=0.10.8.1 && <0.11), Cabal (>=2.0.1.0 && <2.1), clock (>=0.7.2 && <0.8), conduit (>=1.2.12.1 && <1.3), conduit-extra (>=1.1.17 && <1.2), containers (>=0.5.7.1 && <0.6), cryptonite (>=0.23 && <0.25), cryptonite-conduit (>=0.2.2 && <0.3), deepseq (>=1.4.2.0 && <1.5), directory (>=1.3.0.0 && <1.4), echo (>=0.1.3 && <0.2), exceptions (>=0.8.3 && <0.9), extra (==1.6.*), fast-logger (>=2.4.10 && <2.5), file-embed (>=0.0.10 && <0.1), filelock (>=0.1.1.2 && <0.2), filepath (>=1.4.1.1 && <1.5), fsnotify (>=0.2.1.1 && <0.3), generic-deriving (>=1.11.2 && <1.12), gitrev, hackage-security (>=0.5.2.2 && <0.6), hashable (>=1.2.6.1 && <1.3), hastache (>=0.6.1 && <0.7), hpack (>=0.20.0 && <0.21), hpc (>=0.6.0.3 && <0.7), http-client (>=0.5.7.1 && <0.6), http-client-tls (>=0.3.5.1 && <0.4), http-conduit (>=2.2.3.2 && <2.3), http-types (>=0.9.1 && <0.10), memory (>=0.14.8 && <0.15), microlens (>=0.4.8.1 && <0.5), microlens-mtl (>=0.1.11.0 && <0.2), mintty (>=0.1.1 && <0.2), monad-logger (>=0.3.25.1 && <0.4), mono-traversable (>=1.0.4.0 && <1.1), mtl (>=2.2.1 && <2.3), neat-interpolation (>=0.3.2.1 && <0.4), network-uri (>=2.6.1.0 && <2.7), open-browser (>=0.2.1.0 && <0.3), optparse-applicative (>=0.13.2.0 && <0.14 || >=0.14.0.0 && <0.15), optparse-simple, path (>=0.6.1 && <0.7), path-io (>=1.3.3 && <1.4), persistent (>=2.7.1 && <2.8), persistent-sqlite (>=2.6.3 && <2.7), persistent-template (>=2.5.3 && <2.6), pid1 (>=0.1.2.0 && <0.2), pretty (>=1.1.3.3 && <1.2), primitive (>=0.6.2.0 && <0.7), process (>=1.4.3.0 && <1.5 || >=1.6.1.0 && <1.7), project-template (>=0.2.0 && <0.3), regex-applicative-text (>=0.1.0.1 && <0.2), resourcet (>=1.1.9 && <1.2), retry (>=0.7.4.3 && <0.8), semigroups (>=0.18.3 && <0.19), split (>=0.2.3.2 && <0.3), stack, stm (>=2.4.4.1 && <2.5), store (>=0.4.3.2 && <0.5), store-core (>=0.4.1 && <0.5), streaming-commons (>=0.1.17 && <0.2), tar (>=0.5.0.3 && <0.6), template-haskell (>=2.11.1.0 && <2.12 || >=2.12.0.0 && <2.13), temporary (>=1.2.1.1 && <1.3), text (>=1.2.2.2 && <1.3), text-metrics (>=0.3.0 && <0.4), th-reify-many (>=0.1.8 && <0.2), time (>=1.6.0.1 && <1.7 || >=1.8.0.2 && <1.9), tls (>=1.3.11 && <1.4 || >=1.4.0 && <1.5), transformers (>=0.5.2.0 && <0.6), unicode-transforms (>=0.3.3 && <0.4), unix (>=2.7.2.1 && <2.8), unix-compat (>=0.4.3.1 && <0.5 || >=0.5.0.1 && <0.6), unliftio (>=0.2.0.0 && <0.3), unordered-containers (>=0.2.8.0 && <0.3), vector (>=0.12.0.1 && <0.13), Win32 (>=2.3.1.1 && <2.4 || >=2.5.4.1 && <2.6), yaml (>=0.8.25 && <0.9), zip-archive (>=0.3.1.1 && <0.4), zlib (>=0.6.1.2 && <0.7) [details]
License BSD3
Author Commercial Haskell SIG
Maintainer manny@fpcomplete.com
Category Development
Home page http://haskellstack.org
Bug tracker https://github.com/commercialhaskell/stack.git/issues
Source repository head: git clone https://github.com/commercialhaskell/stack.git
Uploaded Thu Dec 7 04:38:38 UTC 2017 by borsboom
Updated Thu Dec 7 05:03:46 UTC 2017 by borsboom to revision 1   [What is this?]
Distributions Arch:1.6.1, Debian:0.1.10.0, LTSHaskell:1.5.1, NixOS:1.6.1, Stackage:1.6.1, Tumbleweed:1.5.1
Executables stack
Downloads 6747 total (1335 in the last 30 days)
Rating 2.0 (votes: 3) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2017-12-07 [all 2 reports]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
disable-git-info

Disable compile-time inclusion of current git info in stack

DisabledManual
hide-dependency-versions

Hides dependency versions from "stack --version", used only by building with stack.yaml

DisabledManual
integration-tests

Run the integration test suite

DisabledManual
static

Pass -static/-pthread to ghc when linking the stack binary.

DisabledManual
supported-build

If false, causes "stack --version" to issue a warning about the build being unsupported. True only if building with stack.yaml

DisabledManual

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees


Readme for stack-1.6.1

[back to package description]

The Haskell Tool Stack

Build Status Windows build status Release

Stack is a cross-platform program for developing Haskell projects. It is intended for Haskellers both new and experienced.

See haskellstack.org or the doc directory for more information.