The hackage-proxy package

[Tags: deprecated, mit, program]

Deprecated

The motivating use case for this is testing packages with newer versions of GHC. In this case, upper bounds on base, process, and a few other packages will often prevent compilation. This proxy will allow you to strip those upper bounds and proceed with compilation. In the future, other features may be added as well, such as package replacement.


Properties

Versions0.1.0.0, 0.2.0.0, 0.2.0.1, 0.2.0.2, 0.3.0, 0.3.0.1
Dependenciesbase (>=4.5 && <5), basic-prelude (>=0.3.6), blaze-builder (>=0.3), bytestring (>=0.9), Cabal (>=1.12), case-insensitive, conduit (>=1.0), containers, filepath, http-client (>=0.2), http-client-conduit (>=0.2), http-conduit (>=2.0), http-types (>=0.7), optparse-applicative (>=0.5), tar (>=0.4), text (>=0.11), transformers (>=0.2), unordered-containers, wai (>=2.0), warp (>=2.0), zlib (>=0.5), zlib-conduit (>=0.5)
LicenseMIT
AuthorMichael Snoyman
Maintainermichael@snoyman.com
CategoryDevelopment
Home pagehttp://github.com/snoyberg/hackage-proxy
Executableshackage-proxy
Upload dateThu Mar 20 08:15:10 UTC 2014
Uploaded byMichaelSnoyman
Downloads447 total (29 in last 30 days)

Downloads

Maintainers' corner

For package maintainers and hackage trustees