io-streams-haproxy: HAProxy protocol 1.5 support for io-streams

[ bsd3, io-streams, library, network ] [ Propose Tags ]

HAProxy protocol version 1.5 support (see http://haproxy.1wt.eu/download/1.5/doc/proxy-protocol.txt) for applications using io-streams. The proxy protocol allows information about a networked peer (like remote address and port) to be propagated through a forwarding proxy that is configured to speak this protocol.

Versions [faq] 1.0.0.0, 1.0.0.1, 1.0.0.2, 1.0.1.0
Dependencies attoparsec (>=0.7 && <0.14), base (>=4.5 && <4.11), bytestring (>=0.9 && <0.11), io-streams (>=1.3 && <1.5), network (>=2.3 && <2.7), transformers (>=0.3 && <0.6) [details]
License BSD-3-Clause
Copyright (c) 2014 Google, Inc. and CONTRIBUTORS
Author Gregory Collins
Maintainer greg@gregorycollins.net
Revised Revision 2 made by DougBeardsley at Tue May 23 13:07:10 UTC 2017
Category Network, IO-Streams
Home page http://snapframework.com/
Bug tracker https://github.com/snapframework/io-streams-haproxy/issues
Source repo head: git clone https://github.com/snapframework/io-streams-haproxy.git
Uploaded by DougBeardsley at Wed Aug 10 23:28:23 UTC 2016
Distributions Arch:1.0.1.0, Debian:1.0.0.2, Fedora:1.0.0.2, LTSHaskell:1.0.1.0, NixOS:1.0.1.0, Stackage:1.0.1.0
Downloads 10384 total (161 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2016-08-10 [all 1 reports]

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees