The safe-failure package

[Tags: bsd3, deprecated, library]

Deprecated

Partial functions from the base library, such as head and !!, modified to fail in a Failure. These functions can be used to reduce the number of unsafe pattern matches in your code.


Properties

Versions0.1, 0.2, 0.4.0, 0.5.0, 0.5.0.1, 0.5.0.2
Dependenciesbase (==4.*), failure (>=0.1.0 && <0.3)
LicenseBSD3
Copyright2007-8, Neil Mitchell
AuthorNeil Mitchell, Jose Iborra (2009), Michael Snoyman (2009)
Maintainerpepeiborra@gmail.com
CategoryFailure
Home pagehttp://www-users.cs.york.ac.uk/~ndm/safe/
Upload dateFri Mar 21 07:38:38 UTC 2014
Uploaded byMichaelSnoyman
Downloads283 total (47 in last 30 days)

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees