The control-monad-failure package

[Tags:deprecated, library, public-domain]
Deprecated.

A class for monads which can fail with an error.

Properties

Versions 0.1, 0.2, 0.3, 0.4, 0.5.0, 0.6.0, 0.6.1, 0.6.1.1, 0.6.1.2, 0.7.0, 0.7.0.1
Dependencies base (>=3 && <5), extensible-exceptions, mtl, pretty, template-haskell, transformers [details]
License PublicDomain
Author Pepe Iborra, Michael Snoyman, Nicolas Pouillard
Maintainer pepeiborra@gmail.com
Stability experimental
Category Control, Monads
Home page http://github.com/pepeiborra/control-monad-failure
Uploaded Mon Nov 2 22:06:23 UTC 2009 by PepeIborra
Distributions NixOS:0.7.0.1
Downloads 2397 total (38 in the last 30 days)
Votes
0 []
Status Docs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefaultType
transformersDisabledAutomatic
extensibleexceptionsinbaseEnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees