The http-conduit package

[Tags: bsd3, library]

This package uses attoparsec for parsing the actual contents of the HTTP connection. It also provides higher-level functions which allow you to avoid direct usage of conduits. See http://www.yesodweb.com/book/http-conduit for more information.

Network.HTTP.Conduit.Browser module has been moved to http://hackage.haskell.org/package/http-conduit-browser/

Properties

Versions1.0.0, 1.0.0.1, 1.1.0, 1.1.0.1, 1.1.1, 1.1.2.2, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.3.0, 1.3.0.1, 1.4.0, 1.4.0.1, 1.4.0.2, 1.4.1, 1.4.1.1, 1.4.1.2, 1.4.1.3, 1.4.1.4, 1.4.1.5, 1.4.1.6, 1.4.1.7, 1.4.1.8, 1.4.1.9, 1.4.1.10, 1.5.0, 1.5.0.1, 1.5.0.2, 1.5.0.3, 1.6.0, 1.6.0.1, 1.6.0.2, 1.6.0.3, 1.6.0.4, 1.6.1, 1.6.1.1, 1.6.1.2, 1.7.0, 1.8.0, 1.8.1, 1.8.2, 1.8.2.1, 1.8.3, 1.8.4, 1.8.4.1, 1.8.4.2, 1.8.4.3, 1.8.4.4, 1.8.4.5, 1.8.5, 1.8.5.1, 1.8.5.2, 1.8.6, 1.8.6.1, 1.8.6.2, 1.8.6.3, 1.8.7, 1.8.7.1, 1.8.8, 1.8.9, 1.9.0, 1.9.1, 1.9.2, 1.9.2.1, 1.9.2.2, 1.9.3, 1.9.4, 1.9.4.1, 1.9.4.2, 1.9.4.3, 1.9.4.4, 1.9.4.5, 1.9.5, 1.9.5.1, 1.9.5.2, 1.9.5.3, 1.9.6, 2.0.0, 2.0.0.1, 2.0.0.2, 2.0.0.3, 2.0.0.4, 2.0.0.5, 2.0.0.6, 2.0.0.7, 2.0.0.8, 2.0.0.9, 2.0.0.10, 2.1.0, 2.1.1, 2.1.2, 2.1.2.1, 2.1.2.2, 2.1.2.3, 2.1.3, 2.1.4, 2.1.4.1, 2.1.4.2, 2.1.4.3, 2.1.4.4, 2.1.4.5, 2.1.4.7, 2.1.5, 2.1.5.1, 2.1.6, 2.1.7, 2.1.7.1, 2.1.7.2, 2.1.8
Change logNone available
Dependenciesasn1-data (>=0.5.1 && <0.8), attoparsec (>=0.8.0.2 && <0.11), attoparsec-conduit (==0.5.*), base (==4.*), base64-bytestring (>=0.1 && <1.1), blaze-builder (>=0.2.1 && <0.4), blaze-builder-conduit (==0.5.*), bytestring (>=0.9.1.4), case-insensitive (>=0.2), certificate (==1.3.*), conduit (==0.5.*), containers (>=0.2), cookie (==0.4.*), cprng-aes (==0.2.*), data-default, deepseq, failure (>=0.1), http-types (>=0.6 && <0.8), lifted-base (>=0.1), monad-control (==0.3.*), mtl, network (>=2.2.1 && <2.2.3 || >=2.3 && <2.6), network-bytestring (==0.1.3.*), regex-compat, resourcet (>=0.3 && <0.5), socks (==0.4.*), text, time, tls (>=1.0.0 && <1.1), tls-extra (>=0.5.0 && <0.6), transformers (>=0.2), transformers-base (==0.4.*), utf8-string (>=0.3.4), void (>=0.5.5 && <0.6), zlib-conduit (==0.5.*) [details]
LicenseBSD3
AuthorMichael Snoyman <michael@snoyman.com>
MaintainerMichael Snoyman <michael@snoyman.com>
StabilityStable
CategoryWeb, Conduit
Home pagehttp://www.yesodweb.com/book/http-conduit
Source repositoryhead: git clone git://github.com/snoyberg/http-conduit.git
UploadedMon Nov 19 14:19:13 UTC 2012 by MichaelSnoyman
UpdatedTue May 26 21:40:57 UTC 2015 by AdamBergmark to revision 2
DistributionsDebian:2.1.8, FreeBSD:2.1.8, LTSHaskell:2.1.8, NixOS:2.1.8, Stackage:2.1.8
Downloads99298 total (1908 in last 30 days)
Votes
1 []
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefaultType
network-bytestringDisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees