unix-compat: Portable POSIX-compatibility layer.

[ bsd3, library, system ] [ Propose Tags ]

This package provides portable implementations of parts of the unix package. This package re-exports the unix package when available. When it isn't available, portable implementations are used.

Versions 0.1, 0.1.1, 0.1.2.0, 0.1.2.1, 0.2, 0.2.1, 0.2.1.1, 0.2.1.2, 0.2.1.3, 0.2.2, 0.2.2.1, 0.3, 0.3.0.1, 0.3.0.2, 0.4.0.0, 0.4.1.0, 0.4.1.1, 0.4.1.3, 0.4.1.4, 0.4.2.0, 0.4.3.0, 0.4.3.1, 0.5, 0.5.0.1 (info)
Dependencies base (==4.*), directory (>=1.0 && <1.2), old-time (==1.0.*), unix (>=2.4 && <2.6) [details]
License BSD-3-Clause
Author Björn Bringert, Duncan Coutts, Jacob Stanley, Bryan O'Sullivan
Maintainer Jacob Stanley <jacob@stanley.io>
Category System
Home page http://github.com/jystic/unix-compat
Source repo head: git clone git://github.com/jystic/unix-compat.git
Uploaded by JacobStanley at Tue Aug 2 17:16:31 UTC 2011
Distributions Arch:0.4.3.1, Debian:0.4.1.4, Fedora:0.5.0.1, FreeBSD:0.4.1.4, LTSHaskell:0.5.0.1, NixOS:0.5.0.1, Stackage:0.5.0.1, openSUSE:0.5.0.1
Downloads 166467 total (177 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Modules

[Index]

Flags

NameDescriptionDefaultType
portable

Force compiling in portable mode, useful for testing.

DisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees