The warp package

[Tags: library, mit]

The premier WAI handler. For more information, see http://steve.vinoski.net/blog/2011/05/01/warp-a-haskell-web-server/.

Changelog

2.0.0
ResourceT is not used anymore. Request and Response is now abstract data types. To use their constructors, Internal module should be imported.
1.3.9
Support for byte range requests.
1.3.7
Sockets now have FD_CLOEXEC set on them. This behavior is more secure, and the change should not affect the vast majority of use cases. However, it appeared that this is buggy and is fixed in 2.0.0.

Properties

Versions0.3.0, 0.3.1, 0.3.2, 0.3.2.1, 0.3.2.2, 0.3.2.3, 0.3.3, 0.4.0, 0.4.0.1, 0.4.1, 0.4.1.1, 0.4.1.2, 0.4.2, 0.4.3, 0.4.3.1, 0.4.4, 0.4.5, 0.4.6, 0.4.6.1, 0.4.6.2, 0.4.6.3, 1.0.0, 1.0.0.1, 1.1.0, 1.1.0.1, 1.2.0, 1.2.0.1, 1.2.0.2, 1.2.1, 1.2.1.1, 1.2.2, 1.3.0, 1.3.0.1, 1.3.1, 1.3.1.1, 1.3.1.2, 1.3.2, 1.3.3, 1.3.3.1, 1.3.3.2, 1.3.3.3, 1.3.4, 1.3.4.1, 1.3.4.2, 1.3.4.3, 1.3.4.4, 1.3.5, 1.3.5.1, 1.3.6, 1.3.7, 1.3.7.1, 1.3.7.2, 1.3.7.3, 1.3.7.4, 1.3.7.5, 1.3.8, 1.3.8.1, 1.3.8.2, 1.3.8.3, 1.3.8.4, 1.3.9, 1.3.9.1, 1.3.9.2, 1.3.10, 1.3.10.1, 1.3.10.2, 2.0.0, 2.0.0.1, 2.0.1, 2.0.2, 2.0.2.1, 2.0.3, 2.0.3.1, 2.0.3.2, 2.0.3.3, 2.0.3.4, 2.1.0, 2.1.1, 2.1.1.1, 2.1.1.2, 2.1.2, 2.1.2.1, 2.1.3, 2.1.3.1, 2.1.3.2, 2.1.3.3, 2.1.4, 2.1.4.1, 2.1.5, 2.1.5.1, 2.1.5.2, 3.0.0, 3.0.0.1, 3.0.0.2, 3.0.0.3, 3.0.0.4, 3.0.0.5, 3.0.0.6, 3.0.0.7, 3.0.0.8, 3.0.1, 3.0.1.1, 3.0.2, 3.0.2.1, 3.0.2.2, 3.0.2.3, 3.0.3, 3.0.4, 3.0.4.1
Dependenciesarray, base (>=3 && <5), blaze-builder (>=0.3.3 && <0.4), blaze-builder-conduit (>=0.5 && <1.1), bytestring (>=0.9.1.4), case-insensitive (>=0.2), conduit (>=0.5 && <1.1), ghc-prim, http-attoparsec, http-date, http-types (>=0.7), lifted-base (>=0.1), network (>=2.2.1.5 && <2.2.3), network-bytestring (==0.1.3.*), network-conduit (>=0.5 && <1.1), simple-sendfile (>=0.2.7 && <0.3), transformers (>=0.2.2 && <0.4), unix, unix-compat (>=0.2), void, wai (==2.0.*) or
array, base (>=3 && <5), blaze-builder (>=0.3.3 && <0.4), blaze-builder-conduit (>=0.5 && <1.1), bytestring (>=0.9.1.4), case-insensitive (>=0.2), conduit (>=0.5 && <1.1), ghc-prim, http-attoparsec, http-types (>=0.7), lifted-base (>=0.1), network (>=2.2.1.5 && <2.2.3), network-bytestring (==0.1.3.*), network-conduit (>=0.5 && <1.1), old-locale, simple-sendfile (>=0.2.7 && <0.3), time, transformers (>=0.2.2 && <0.4), unix-compat (>=0.2), void, wai (==2.0.*) or
array, base (>=3 && <5), blaze-builder (>=0.3.3 && <0.4), blaze-builder-conduit (>=0.5 && <1.1), bytestring (>=0.9.1.4), case-insensitive (>=0.2), conduit (>=0.5 && <1.1), ghc-prim, http-attoparsec, http-date, http-types (>=0.7), lifted-base (>=0.1), network (>=2.3), network-conduit (>=0.5 && <1.1), simple-sendfile (>=0.2.7 && <0.3), transformers (>=0.2.2 && <0.4), unix, unix-compat (>=0.2), void, wai (==2.0.*) or
array, base (>=3 && <5), blaze-builder (>=0.3.3 && <0.4), blaze-builder-conduit (>=0.5 && <1.1), bytestring (>=0.9.1.4), case-insensitive (>=0.2), conduit (>=0.5 && <1.1), ghc-prim, http-attoparsec, http-types (>=0.7), lifted-base (>=0.1), network (>=2.3), network-conduit (>=0.5 && <1.1), old-locale, simple-sendfile (>=0.2.7 && <0.3), time, transformers (>=0.2.2 && <0.4), unix-compat (>=0.2), void, wai (==2.0.*)
LicenseMIT
AuthorMichael Snoyman, Kazu Yamamoto, Matt Brown
Maintainermichael@snoyman.com
StabilityStable
CategoryWeb, Yesod
Home pagehttp://github.com/yesodweb/wai
Source repositoryhead: git clone git://github.com/yesodweb/wai.git
UploadedTue Dec 10 12:32:41 UTC 2013 by KazuYamamoto
DistributionsDebian:3.0.0.5, Fedora:1.3.8.4, FreeBSD:1.3.8.1, NixOS:3.0.4, Stackage:3.0.4
Downloads76099 total (3450 in last 30 days)
StatusDocs available [build log]
Successful builds reported [all 1 reports]

Modules

[Index]

Flags

NameDescriptionDefault
network-bytestringDisabled
allow-sendfilefdAllow use of sendfileFd (not available on GNU/kFreeBSD)Enabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees