The prettyprinter-ansi-terminal package

[Tags:bsd2, library]

See README.md


[Skip to Readme]

Properties

Versions 0.1, 1, 1.0.1, 1.1 (info)
Change log CHANGELOG.md
Dependencies ansi-terminal (>=0.4.0 && <0.7), base (>=4.7 && <5), prettyprinter (<1.2), semigroups (>=0.1 && <0.19), text (==1.2.*) [details]
License BSD2
Author David Luposchainsky
Maintainer David Luposchainsky <dluposchainsky at google>
Category User Interfaces, Text
Home page http://github.com/quchen/prettyprinter
Bug tracker http://github.com/quchen/prettyprinter/issues
Source repository head: git clone git://github.com/quchen/prettyprinter.git
Uploaded Thu Jun 22 13:04:49 UTC 2017 by quchen
Distributions NixOS:1.1, Stackage:1.1
Downloads 169 total (136 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2017-06-22 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Readme for prettyprinter-ansi-terminal

Readme for prettyprinter-ansi-terminal-1.1

ANSI terminal prettyprinter renderer

This package defines a renderer for documents generated by the prettyprinter package, suitable for displaying them on ANSI-compatible terminals, including colors, boldening, underlining and italication.

For more information about the prettyprinter in general, refer to the main prettyprinter package documentation.