prettyprinter-compat-ansi-wl-pprint: Drop-in compatibility package to migrate from »ansi-wl-pprint« to »prettyprinter«.

[ bsd2, library, text, user-interfaces ] [ Propose Tags ]

See README.md


[Skip to Readme]
Versions 0.1, 1, 1.0.1 (info)
Dependencies base (>=4.7 && <5), prettyprinter (<2), prettyprinter-ansi-terminal (==1.1.*), text (==1.2.*) [details]
License BSD-2-Clause
Author David Luposchainsky
Maintainer David Luposchainsky <dluposchainsky at google>
Revised Revision 1 made by quchen at Mon Feb 19 09:16:33 UTC 2018
Category User Interfaces, Text
Home page http://github.com/quchen/prettyprinter
Bug tracker http://github.com/quchen/prettyprinter/issues
Source repo head: git clone git://github.com/quchen/prettyprinter.git
Uploaded by quchen at Fri Jun 23 07:45:07 UTC 2017
Distributions LTSHaskell:1.0.1, NixOS:1.0.1, Stackage:1.0.1
Downloads 1030 total (28 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2017-06-23 [all 1 reports]
Hackage Matrix CI

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees


Readme for prettyprinter-compat-ansi-wl-pprint-1.0.1

[back to package description]

ansi-wl-pprint compatibility package

This package defines a compatibility layer between the old ansi-wl-pprint package, and the new prettyprinter/prettyprinter-ansi-terminal ones.

This allows easily transitioning dependent packages from the old to the new package, by simply replacing ansi-wl-pprint with prettyprinter-ansi-terminal in the .cabal file.

Note that this package is only for transitional purposes, and therefore deprecated and wholly undocumented. For new development, use the current version of prettyprinter, and the ANSI terminal backend provided in prettyprinter-ansi-terminal.