binary-orphans: Compatibility package for binary; provides instances

[ binary, bsd3, compatibility, data, library, parsing ] [ Propose Tags ]

This package provides instances defined in later versions of binary package

Prior version 1 this packages provided instances for other packages. That functionality is moved to binary-instances package.

Versions [faq] 0.1.0.0, 0.1.1.0, 0.1.2.0, 0.1.3.0, 0.1.4.0, 0.1.5.0, 0.1.5.1, 0.1.5.2, 0.1.6.0, 0.1.7.0, 0.1.8.0, 1, 1.0.1
Change log CHANGELOG.md
Dependencies base (>=4.5 && <4.14), binary (>=0.5.1.0 && <0.6 || >=0.7.1.0 && <0.8 || >=0.8.3.0 && <0.8.8), fail (==4.9.*), nats (>=1.1.2 && <1.2), semigroups (>=0.18.5 && <0.19.1), transformers (>=0.3.0.0 && <0.7), void (>=0.7.3 && <0.8) [details]
License BSD-3-Clause
Author Oleg Grenrus <oleg.grenrus@iki.fi>
Maintainer Oleg Grenrus <oleg.grenrus@iki.fi>
Revised Revision 1 made by phadej at Mon Jun 17 12:54:28 UTC 2019
Category Data, Binary, Parsing, Compatibility
Source repo head: git clone git://github.com/phadej/binary-orphans.git
Uploaded by phadej at Mon May 13 18:55:47 UTC 2019
Distributions Arch:0.1.8.0, Debian:0.1.8.0, LTSHaskell:0.1.8.0, NixOS:1.0.1, Stackage:1.0.1
Downloads 10825 total (378 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-05-13 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees