The transformers-compat package

[Tags:bsd3, library]

This package includes backported versions of types that were added to transformers in transformers 0.3 for users who need strict transformers 0.2 compatibility to run on old versions of the platform, but also need those types.

Those users should be able to just depend on transformers >= 0.2 and transformers-compat.

Note: missing methods are not supplied but this at least permits the types to be used.

[Skip to Readme]


Versions 0.1, 0.1.1,, 0.2, 0.3, 0.3.2, 0.3.3,,,,,,,,,,,,
Change log CHANGELOG.markdown
Dependencies base (>=4.3 && <5), transformers (>=0.2 && <0.4) [details]
License BSD3
Copyright Copyright (C) 2012 Edward A. Kmett
Author Edward A. Kmett
Maintainer Edward A. Kmett <>
Stability provisional
Category Compatibility
Home page
Bug tracker
Source repository head: git clone git://
Uploaded Sun Dec 23 15:38:22 UTC 2012 by EdwardKmett
Distributions Arch:, Debian:, Fedora:, FreeBSD:, LTSHaskell:, NixOS:, Stackage:, Tumbleweed:
Downloads 143304 total (60 in the last 30 days)
1 []
Status Docs not available [build log]
Last success reported on 2015-06-09 [all 5 reports]


  • Control
    • Applicative
      • Control.Applicative.Backwards
      • Control.Applicative.Lift
  • Data
    • Functor
      • Data.Functor.Reverse



Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info


Maintainer's Corner

For package maintainers and hackage trustees

Readme for transformers-compat

Readme for transformers-compat-0.1


Build Status

This provides a thin compatibility shim on top of transformers-0.2 to add the types that were added in transformers-0.3.

This enables users to maintain haskell-platform compatibility, while still gaining access ot the new functionality.

Contact Information

Contributions and bug reports are welcome!

Please feel free to contact me through github or on the #haskell IRC channel on

-Edward Kmett