time-compat: Compatibility package for time

[ bsd3, compatibility, library, time ] [ Propose Tags ]

This packages tries to compat as much of time features as possible.

TODO:

Versions [faq] 0.1.0, 0.1.0.1, 0.1.0.2, 0.1.0.3, 1.9.2, 1.9.2.1, 1.9.2.2
Dependencies base (>=4.3 && <4.14), base-orphans (>=0.8.1 && <0.9), deepseq (>=1.3.0.0 && <1.4 || >=1.4.1.1 && <1.5), fail (>=4.9.0.0 && <4.10), old-locale (>=1.0.0.2 && <1.1), semigroups (>=0.18.5 && <0.20), time (==1.2.* || >=1.4 && <1.7 || ==1.8.* || >=1.9.2 && <1.9.4) [details]
License BSD-3-Clause
Author Ashley Yakeley
Maintainer Oleg Grenrus <oleg.grenrus@iki.fi>
Revised Revision 1 made by phadej at Fri May 24 18:05:14 UTC 2019
Category Time, Compatibility
Home page https://github.com/phadej/time-compat
Bug tracker https://github.com/phadej/time-compat/issues
Source repo head: git clone https://github.com/phadej/time-compat.git
Uploaded by phadej at Mon May 13 13:13:46 UTC 2019
Distributions Arch:1.9.2.2, Debian:0.1.0.3, Fedora:0.1.0.3, FreeBSD:0.1.0.3, LTSHaskell:0.1.0.3, NixOS:1.9.2.2, Stackage:1.9.2.2, openSUSE:1.9.2.2
Downloads 18293 total (440 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-05-13 [all 1 reports]

Modules

[Index] [Quick Jump]

Flags

NameDescriptionDefaultType
old-locale

If true, use old-locale, otherwise use time 1.5 or newer.

DisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees