The representable-functors package

[Tags: bsd3, deprecated, library]

Deprecated in favor of adjunctions

Representable functors


Properties

Versions0.1.0, 0.1.0.1, 0.1.0.2, 0.2.0, 0.3.0, 0.3.0.1, 0.3.0.2, 0.3.0.3, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.5.0, 1.8.0, 2.0, 2.0.0.1, 2.0.0.3, 2.0.0.4, 2.0.0.5, 2.0.1, 2.0.2, 2.1, 2.1.2, 2.2, 2.2.1, 2.2.1.1, 2.4, 2.4.0.1, 2.4.0.2, 2.5, 3.0, 3.0.0.1, 3.0.0.2, 3.0.0.3, 3.0.1, 3.1, 3.2.0.1, 3.2.0.2
Dependenciesarray (>=0.3.0.2 && <0.5), base (==4.*), comonad (==3.0.*), comonad-transformers (==3.0.*), comonads-fd (==3.0.*), containers (>=0.3 && <0.6), contravariant (>=0.2.0.1 && <0.3), distributive (>=0.2.2 && <0.4), free (>=3.0 && <3.4), keys (==3.0.*), mtl (>=2.0.1.0 && <2.2), semigroupoids (==3.0.*), semigroups (>=0.8.3.1 && <0.9), transformers (>=0.2 && <0.4)
LicenseBSD3
CopyrightCopyright (C) 2011 Edward A. Kmett
AuthorEdward A. Kmett
MaintainerEdward A. Kmett <ekmett@gmail.com>
Stabilityprovisional
CategoryMonads, Functors, Data Structures
Home pagehttp://github.com/ekmett/representable-functors/
Bug trackerhttp://github.com/ekmett/representable-functors/issues
Source repositoryhead: git clone git://github.com/ekmett/representable-functors.git
Upload dateSun Jan 6 17:51:49 UTC 2013
Uploaded byEdwardKmett
DistributionsDebian:2.4.0.2
Downloads3693 total (310 in last 30 days)

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees