The monads-fd package

[Tags: bsd3, deprecated, library]

Deprecated in favor of mtl

Monad classes using functional dependencies, with instances for various monad transformers, inspired by the paper Functional Programming with Overloading and Higher-Order Polymorphism, by Mark P Jones, in Advanced School of Functional Programming, 1995 (http://web.cecs.pdx.edu/~mpj/pubs/springschool.html).

This package is almost a compatible replacement for the mtl package. Client packages will need to depend on this one and on transformers.

Properties

Versions0.0.0.0, 0.0.0.1, 0.1.0.0, 0.1.0.1, 0.1.0.2, 0.1.0.3, 0.1.0.4, 0.2.0.0
Change logNone available
Dependenciesbase, transformers (>=0.1.4.0 && <0.2) [details]
LicenseBSD3
AuthorAndy Gill
MaintainerRoss Paterson <ross@soi.city.ac.uk>
CategoryControl
UploadedSun Mar 22 12:27:38 UTC 2009 by RossPaterson
UpdatedThu Jan 15 14:21:39 UTC 2015 by HerbertValerioRiedel to revision 1
Downloads1523 total (61 in last 30 days)
Votes
0 []
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Downloads

Maintainers' corner

For package maintainers and hackage trustees