The functor-apply package

[Tags: bsd3, deprecated, library]

Deprecated in favor of semigroupoids

Provides a wide array of semigroup based Functors.

When working with comonads you often have the <*> portion of an Applicative, but not the pure. This was captured in Uustalu and Vene's "Essence of Dataflow Programming" in the form of the ComonadZip class in the days before Applicative, manifested here as ComonadApply.

Logically:

 Functor ---> Apply --------> Bind
    |           |              |
    |           v              v
    |      Applicative ---> Monad
    |           |              |
    v           v              v
   Alt ->  Alternative -> MonadPlus

This lets us remove many of the restrictions from various monad transformers as in many cases the binding operation or <*> operation does not require them.

Finally, to work with these weaker structures it is beneficial to have containers that can provide stronger guarantees about their contents, so versions of Traversable and Foldable that can be folded with just a Semigroup are added.


Properties

Versions0.5.0, 0.6.0, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.4.1, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.0.1, 0.10.0.2, 0.10.0.3, 0.10.1, 0.10.3, 0.10.4, 0.10.5, 0.11
Dependenciesbase (>=4 && <4.4), comonad (>=0.9.0 && <1.0), containers (>=0.4.0 && <0.5), semigroups (>=0.3.2 && <0.4), transformers (>=0.2.0 && <0.3)
LicenseBSD3
CopyrightCopyright (C) 2011 Edward A. Kmett
AuthorEdward A. Kmett
MaintainerEdward A. Kmett <ekmett@gmail.com>
Stabilityprovisional
CategoryControl, Comonads
Home pagehttp://comonad.com/reader/
Upload dateFri Jan 28 01:57:42 UTC 2011
Uploaded byEdwardKmett
Downloads896 total (94 in last 30 days)

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees